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Lotus DUC 1.2.5 and Domino Linux Support
This document describes the changes that IBM made in DUC 1.2.5, includes tables for the supported client and server version combinations, and provides some troubleshooting information. Additionally, a list of defects (both found and fixed) is provided.
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1 Terminology/Acronyms

	DUC
	IBM Lotus Domino Unified Communications (DUC) is a set of software that integrates with Domino and IBM Lotus Notes to provide Cisco Unity subscribers with access to their voice mail and e-mail, through either their Lotus Notes or Domino Web Access/iNotes client or their telephone. DUC consists of a server component, an administration component, and a client component that you install using separate installation programs. Refer to the IBM Lotus Domino Unified Communications for Cisco Administration Guide for more details.

	RHEL
	RedHat Enterprise Linux 

	SLES
	Novell SUSE Linux Enterprise Server

	SUSE
	The name people commonly use to refer to the Novell Linux  distribution. See http://en.wikipedia.org/wiki/SuSE for a history. 


2 DUC 1.2.5 Changes

DUC 1.2.5 contains the following new features, enhancements, and support changes:

· Inclusion of the latest Cisco telephone record and playback (TRaP) component, AvTrapConnectionHolderSvr.exe. 

· Addition of AIX 6.1 server support

· Removal of support for AIX 5.1 and AIX 5.2

· Support for Domino and Notes versions 8.5 and 8.0.2
· Removal of support for Domino 6.5
· Addition of DUC server support for Linux (SUSE Linux Enterprise Server and Red Hat)

· Addition of DUC server support for 64-bit Windows 2003

NOTE: For 64-bit operating systems, DUC supports only the 32-bit version of Domino. The 64-bit version of Domino is not supported.

This section describes the above changes in more detail.

2.1 Updated AvTrapConnectionHolderSvr

DUC 1.2.5 includes an updated version of the AvTrapConnectionHolderSvr.exe component provided by Cisco.  This component provide telephone record and playback (TRaP) functionality in the Notes client and in Domino Web Access (DWA). 
The version of AvTrapConnectionHolderSvr.exe included with DUC 1.2.5 is the same version that is included in Unity 7.0(2)ES1, which has a defect fix for:

· CSCsq79007—DUC124: TRaP fails in Domino PCA and Notes 8 on Vista in workgroup
The AvTrapConnectionHolderSvr.exe in DUC 1.2.4 and DUC 1.2.5 includes changes that:

· Allow the DUC client to function on Windows Vista.

· Obviate the need for enabling anonymous DCOM on client workstations.

Because this anonymous DCOM  issue is kind of confusing, I’ve included the following section from the DUC 1.2.4 TAC Release Notes, just as a reminder. There’s a registry key that you have to set on Unity 5.0 servers to get TRaP in DUC 1.2.4 and DUC 1.2.5 clients to work. If customers with Unity 5.0 who have recently upgraded to DUC 1.2.4 or 1.2.5 call in with a TRaP problem in Notes, one of the first things to check is for the registry key described in the next section.
2.1.1 About the Anonymous DCOM Issue on the Client
TRaP uses anonymous access in Lotus Notes. Starting with Windows XP SP2, the anonymous logon for remote access is turned off by default. To get TRaP to work with DUC 1.2.3, you have enable anonymous logon for remote access on each client workstation. As you can imagine, customers were not happy about doing this on every user’s workstation. This issue is tracked in the following defects: 
· Record and playback by phone in Lotus Notes fails  - CSCef57086
· AvMMProxy changes to allow anonymous access - CSCsk84997
· Dom: csClient change to allow anonymous remote access - CSCsk85481
With the updated AvTrapConnectionHolderSvr.exe in DUC 1.2.4 and DUC 1.2.5, anonymous logon for remote access no longer needs to be enabled on each client workstation. However, for TRaP to work in Notes and DWA with DUC 1.2.4 and DUC 1.2.5, customers must have the updated AvMMProxy that allows anonymous remote access, otherwise TRaP fails. 
In Unity 5.0(1), ES48 and later includes the change to AvMMProxy to allow anonymous access. To enable the change in ES48 and later, you have to create a new registry DWORD key called ProxyTrapIStream within
HKEY_LOCAL_MACHINE\Software\Active Voice\Commserver Setup\1.0\Properties
and set it to 1. 
The change to AvMMProxy has been rolled into Unity 7.0(2), and it is enabled by default; there’s no registry key to set. 

2.2 Updated Domino Server Support
The major change with DUC 1.2.5 is the addition of support for Linux on the Domino server. But there are other OS and Domino server support changes as well.

OS support changes:
· Addition of Linux support
Numerous versions of Novell SUSE Linux Enterprise Server (SLES) and RedHat Enterprise Linux (RHEL) will be supported, as detailed in the next section.

· Addition of AIX 6.1 server support

· Removal of support for AIX 5.1 and AIX 5.2

· Addition of 64-bit Windows 2003 support 
Domino support changes:
· Support for Domino version 8.0.2 (which was released end of August, 2008).
· Support for Domino 8.5 when it is released (should be released in November, 2008)
· Removal of support for Domino 6.5
2.2.1 Full List of Supported Linux Distributions

DUC 1.2.5 will be supported on Novell SUSE Linux Enterprise Server (SLES) and RedHat Enterprise Linux (RHEL). The versions of SLES and RHEL supported depends on the Domino version, as follows (which I’ve copied and pasted from IBM’s DUC Admin Guide):

Domino 8.x 
1. SLES 10 x86 (32-bit)

2. SLES 10 x86_64 (64-bit) 

3. RHEL 5 (32-bit)
Note: XGL and SELinux must be disabled

4. RHEL 5 (64-bit)
Note: XGL and SELinux must be disabled  
Domino 7.0.3

1. SLES 8 (32-bit)

a. Requires Service Pack 3:  Kernel version 2.4.21-107 (or higher).

b. pstack-1.1.7.IBM-1 - downloaded from ftp.suse.com.  The location is /pub/projects/pstack/sles8-i386.

2. SLES 9 (32-bit)

a. Requires Service Pack 1 (or higher)

b. gdb 6.3 may be needed on x86 if issues with stacks in nsd

3. SLES 9 (64-bit) 

a. Requires Service Pack 3 (or higher)

b. Requires gdb patch #11023 (http://support.novell.com/techcenter/psdb/0d6d6938265b52989db3a271f0872fc8.html)

4. RHEL 4 (32-bit)

a. Requires Update 1 (or higher)

b. If using RHEL 4 Update 1, you may need to run "up2date gdb" to address an issue with gdb-6.3.0.0-0.31

5. RHEL 4 (64-bit)

a. Requires Update 3 (or higher)

b. RHEL 4 Update 2 is also supported, provided the user downloads and installs the gdb from Update 3.

6. RHEL 5 (32-bit)

7. RHEL 5 (64-bit) 

a. Requires compat-libstdc++-33.3.2.3-61.i386.rpm, which is not installed by default.  Domino will fail to launch without this file.

2.2.2 Supported Version Combinations of Software on Domino and Unity Servers  
The Unity 5.0(1) requirements are the same as for Unity 7.0(2) – except that we will not officially support Notes 8 on the Unity 5.0 server because of the need to apply ES49 after Unity setup part 1 (where the files are copied to the server) and before running Service Config Wizard and Message Store Config Wizard (see CSCsq33131 “DUC 124: MSCW needs to support Notes 8 on the Unity server” and CSCsq33110  “DUC 124: SCW syscheck needs to allow Notes 8”).

TBD if we will support Notes 8.5 (scheduled to be released in November of 2008) on the Unity server because of  CSCsr52341 DUC125: SCW syscheck needs to allow Notes 8.5.
	DUC Version on Domino Server
	Domino Server Versions
	Notes Version on Unity Server
	OS on Domino Server 

	1.2.5
	8.5.x  32-bit

8.0.x  32-bit

7.0.x
	TBD: 8.5.x

8.0.x

7.0.x

6.5.4 and later
	IBM AIX 5.3, TL7 or later with 64-bit kernel

IBM AIX 6.1 with 64-bit kernel

Windows 2000

Windows 2003 32-bit

Windows 2003 64-bit

SLES (See details ins section 1.2.1)

RHEL (See details in section 1.2.2)

	1.2.4
	8.0.x 32-bit

7.0.x
6.5.4 and later
	8.0.x

7.0

6.5.4 and later
	IBM AIX 5.3 with 64-bit kernel 

Windows Server 2003 32-bit 

Windows Server 2000

	1.2.3
	7.0.x
6.5.x
	7.0

6.5.x
	IBM AIX 5.3 

IBM AIX 5.2 

IBM AIX 5.1 

(Either 64- or 32-bit kernel)

Windows Server 2003 32-bit

Windows Server 2000


2.3 Updated Windows Client Platform Support
Although support of Domino server 6.5 is dropped with DUC 1.2.5, the Notes client 6.5.4+ will continue to be supported with DUC 1.2.5, on both subscriber workstations and on the Unity server. In other words, if a customer currently has Notes 6.5.4 installed on the Unity server, and is upgrading to DUC 1.2.5, they do not need to upgrade Notes on the Unity server.
2.3.1 Supported Version Combinations of Software on Subscriber Workstations
The following table shows the supported version combinations of software on subscriber workstations.  

NOTE: Internet Explorer versions 6 and 7 are the only browsers supported for use with Domino Web Access and iNotes for accessing voice messages with DUC. 

Linux and MAC OS are not supported for use on client workstations.
	Windows Vista 

Enterprise (x86),   Business (x86),   Business N (x86)

	DUC Client Version Workstation
	Notes Client Version on Workstation
	DWA or iNotes Version 

	1.2.5
	· 8.5.x

· 8.0.x
	· DWA 8.5.x

· DWA 8.0.x

	1.2.4 
	· 8.0.x

	· DWA 8.0.x


	Windows XP

	DUC Client Version Workstation
	Notes Client Version on Workstation
	DWA or iNotes Version 

	1.2.5
	· 8.5.x

· 8.0.x

· 7.0.x

· 6.5.4 and later
	· DWA 8.5.x

· DWA 8.0.x

· DWA 7.0.x

· iNotes 6.5.4 and later



	1.2.4


	· 8.0.x

· 7.0.x

· 6.5.4 and later
	· DWA 8.0.x
· DWA 7.0.x
· iNotes 6.5.4 and later

	1.2.3

	· 7.0.x

· 6.5.x
	· DWA 7.0.x

· iNotes 6.5.x


	Windows 2000 Professional

	DUC Client Version Workstation
	Notes Client Version on Workstation
	DWA or iNotes Version 

	1.2.5

	· 8.5.x

· 8.0.x

· 7.0.x 
· 6.5.4 and later


	· DWA 8.5.x

· DWA 8.0.x
· DWA 7.0.x

· iNotes 6.5.4 and later

	1.2.4


	· 8.0.x

· 7.0.x 
· 6.5.4 and later
	· DWA 8.0.x
· DWA 7.0.x
· iNotes 6.5.4 and later

	1.2.3 
	· 7.0.x

· 6.5.x

	· DWA 7.0.x

· iNotes 6.5.x


3 Which DUC 1.2.5 .iso File to Download

There are two versions of the DUC 1.2.5 .iso file posted on the Cisco download site. The only difference in these files is that one has a license agreement from IBM, and the other has a license agreement from Cisco. 

· CISCODUC125.iso contains the IBM license 
· CISCODUC125_CS.iso contains the Cisco license
Customers who originally purchased DUC through IBM and still have active DUC maintenance support contracts through IBM should download CISCODUC125.iso. During the installation of the DUC 1.2.5 components, you will be presented with and asked to accept the IBM license.

New customers and customers who originally purchased DUC through Cisco should download CISCODUC125_CS.iso. During the installation of the DUC 1.2.5 components, you will be presented with and asked to accept the Cisco license.
4 Supported Unity Versions  
DUC 1.2.5 have been qualified for both Cisco Unity 7.0(2) and 5.0(1), but there are two things to note with Unity 5.0(1):

1. As discussed in the About the Anonymous DCOM Issue on the Client section, in order for TRaP to work in the Notes client or Domino Web Access, customers must obtain and install ES48 or later. 

2. The decision was made to not officially support Notes 8 on the Unity 5.0 server. The reason for this decision is that during Unity Setup, the Service Configuration Wizard (SCW) and the Message Store Configuration Wizard (MSCW) error out when Notes 8 is on the Unity server. These issues are tracked in the following two defects:

· CSCsq33110 — DUC 124: SCW syscheck needs to allow Notes 8 
The fix was just a simple change to SysCheck to allow Notes 8.

· CSCsq33131 — DUC 124: MSCW needs to support Notes 8 on the Unity server 
MSCW needed to be updated to look for the mail8.ntf template when creating the default accounts. It already looks for mail7.ntf and mail6.ntf.

Other than that, having Notes 8 on the Unity server should not be a problem. According to IBM, Notes 8 is API compatible with earlier versions of Notes. 

The Cisco Unity 5.0 System Requirements document does not list Notes 8 as supported on the Cisco Unity 5.0 server. However, 5.0(1) ES49 has the changes to SCW and MSCW that will allow Notes 8 to be installed on the Unity server. If a customer doing a new install of Unity 5.0(1) hits this problem, they’ve got two choices: 

· Uninstall Notes 8 and install Notes 7 (or 6.5.4 or later).
· Obtain ES49 from TAC, with the following instructions:

1. After the Unity Setup part 1 reboot (where the files are copied onto the server), exit out of the Cisco Unity Installation and Preparation Assistant (CUICA).
2. Install ES49 and reboot.

3. Continue to the next step in CUICA, which is launching Service Configuration Wizard.  
5 Documentation Updates

This section describes required updates to the customer-facing documentation on cisco.com.

1. Table 1 in the “Compatibility Matrix: Cisco Unity and the Software on Subscriber Workstations” document will be updated as described in the Supported Version Combinations of Software on Subscriber Workstations section.
2. Table 1 in the “System Requirements for Cisco Unity Release 5.0” and “System Requirements for Cisco Unity Release 7.x” documents will be updated as described in the Supported Version Combinations of Software on Domino and Unity Servers section.
3. Post the entire contents of IBM’s DUC 1.2.5 Admin Guide on cisco.com. Starting with DUC 1.2.5, IBM produced a PDF version of the guide (previously, it had been in the Lotus .nsf format, which requires Notes to open/read the guide), which makes it easy for tech pubs to post. The guide contains instructions for installing and uninstalling all the DUC components.
4. Post a DUC 1.2.5 Readme on cisco.com that describes new features and support changes, and how to upgrade to DUC 1.2.5 from previous versions. At some point in the future, tech pubs will migrate this information to the Unity Reconfiguration Guide.
6 Vista and Domino Web Access

On Vista, before running Domino Web Access for the first time, you have to make the Domino server that's hosting the user's mail file a trusted site in Internet Explorer. Otherwise the Vista security policies won't allow the TRaP/CTI components to be installed.
7 About Updating a User’s Mail File Design

As with DUC 1.2.4, after the DUC 1.2.5 csClient component is installed on a user’s computer, the user’s mail file design must be manually updated. How to update the mail file design is documented in the DUC 1.2.5 Admin Guide.
8 Client Troubleshooting
If a customer has encountered a problem with playing or recording voice messages in either Notes or Domino Web Access, the first step in troubleshooting should always be:

· Check the Windows Firewall. If it’s on, either disable it or make an exception for AvTrapConnectionHolderSvr.exe.

· From the Notes client having difficulty, ping the Unity server name and the Domino server name. This should be done using only the local part of the host name, for example: Unityserver as opposed to the FQDN Unityserver.telecom.acme.com. If you can not ping using this short name then playing and recording voice messages in either Notes or Domino Web Access will not work. Either resolve the problem in DNS or add entries to the hosts file on the client computer.
· For Unity 5.0, make sure the customer is at ES48 or later, and that the following registry key is set on the Unity server:
HKEY_LOCAL_MACHINE\Software\Active Voice\Commserver Setup\1.0\Properties

DWORD: ProxyTrapIStream = 1

8.1 TRaP Logging

If problems with TRaP are encountered, enable both DUC and AvTrapConnectionHolderSvr logging as follows.
 To Enable AvTrapConnectionHolderSvr Logging
1. Download DebugView for Windows from:
http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx, to the client computer.
2. On the client computer, run regedit.
3. Go to HKEY_CURRENT_USER\Software\Cisco Systems\Cisco Unity\Media Master.
4. Add a DWORD called "Trace" and set it to 1.
5. Double-click Dbgview.exe. 

6. On the Options menu, make sure Clock Time and Show Milliseconds are checked. 

7. At this point, you have a choice: click File > Log to File, and enter a filename, or when you're done with the test, click File > Save As, and enter a filename. The "Save As" writes to file everything that is on the DebugView display window. To clear that window, click Edit > Clear Display.
Be sure to either delete the Trace registry key or set the Trace registry key to 0 when you are finished.
To Enable DUC Logging
1. Run regedit. 

2. Go to HKEY_CURRENT_USER\Software\Lotus\DUCS. 

3. Create a new DWORD with the name DebugFlags. 

4. Set the value to hex FFF. 

5. This creates a file called LotusUC.csv in the directory where Notes is installed, which by default for Notes 8 is: C:\Program Files\IBM\Lotus\Notes.
This file gets really big quickly. So set DebugFlags back to 0 when you're finished with the test and delete the file.
9 Defects Verified During Testing

The following defects were verified as fixed during the DUC 1.2.5 testing effort. 
	
	Defect
	Headline

	1. 
	CSCsq79007
	DUC124: TRaP fails in Domino PCA and Notes 8 on Vista in workgroup

	2. 
	CSCsr21092
	DUC124: TRaP plays to phone but subsequent attempts show 'Disconnected'

	3. 
	CSCsr20998
	DUC124:TRaP in DWA displays 'Object is not connected to server'

	4. 
	CSCsr26651
	DUC124: Add/Remove Programs does not completely uninstall DUC124

	5. 
	CSCsr26724
	DUC124: Attempting to install DUC before Notes results in bogus error.

	6. 
	CSCsu50388
	Unity loses connection to Domino server during load test


10 Defects Found During Testing

The following defects were found during the DUC 1.2.5 test effort, but have not been fixed yet. We hope to get CSCsu61656 and CSCsu73174 fixed within the next few weeks and into a Unity 7.0 ES. 
	1. 
	Defect
	Headline

	1. 
	CSCsr92707
	DUC125: MSCW fails to create mail files for default accounts

	2. 
	CSCsu61656
	Unity does not detect clustermate when Domino partner is down

	3. 
	CSCsu73174
	Dom: Sub-to-sub messages disappear when partner server down
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