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Lotus DUC 1.2.4 and Domino 8 / Notes 8 Support
This document describes the changes that IBM made in DUC 1.2.4, includes tables for the supported client and server version combinations, and provides some troubleshooting information. Additionally, a list of defects opened during the DUC 1.2.4 and Domino 8 / Notes 8 qualification is provided.
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1 DUC 1.2.4 Changes

This section describes the changes that IBM has made to DUC 1.2.4.

1.1 Updated AvTrapConnectionHolderSvr

DUC 1.2.4 includes an updated version of the AvTrapConnectionHolderSvr.exe CTI component provided by Cisco.  This component provide telephone record and playback (TRaP) functionality in the Notes client and in Domino Web Access. The version of AvTrapConnectionHolderSvr.exe included with DUC 1.2.4 is the same version included in Unity 7.0(2). Cisco has made a number of defect fixes to AvTrapConnectionHolderSvr.exe since the version that was included with DUC 1.2.3. But the main reasons for including the new AvTrapConnectionHolderSvr.exe in DUC 1.2.4 are:
· To allow the DUC client to function on Windows Vista.

· To obviate the need for enabling anonymous DCOM on client workstations.

1.1.1 About the Anonymous DCOM Issue on the Client
TRaP uses anonymous access in Lotus Notes. Starting with Windows XP SP2, the anonymous logon for remote access is turned off by default. To get TRaP to work with DUC 1.2.3, you have enable anonymous logon for remote access on each client workstation. As you can imagine, customers were not happy about doing this on every user’s workstation. This issue is tracked in the following defects: 
· Record and playback by phone in Lotus Notes fails  - CSCef57086
· AvMMProxy changes to allow anonymous access - CSCsk84997
· Dom: csClient change to allow anonymous remote access - CSCsk85481
With the updated AvTrapConnectionHolderSvr.exe in DUC 1.2.4, anonymous logon for remote access no longer needs to be enabled on each client workstation. However, for TRaP to work in DUC 1.2.4, customers must have the updated AvMMProxy that allows anonymous remote access, otherwise TRaP fails. 
In Unity 5.0(1), ES48 includes the change to AvMMProxy to allow anonymous access. To enable the change in ES48, you have to create a new registry DWORD key called ProxyTrapIStream within
HKEY_LOCAL_MACHINE\Software\Active Voice\Commserver Setup\1.0\Properties
and set it to 1. 
The change to AvMMProxy has been rolled into Unity 7.0(2), and it is enabled by default; there’s no registry key to set. 

1.2 Updated Windows Client Platform Support
DUC 1.2.4 adds support for Windows Vista. In other words, Windows Vista requires DUC 1.2.4, and is not supported with DUC 1.2.3. Additionally: 

· DUC 1.2.4 will continue to support Windows XP and Windows 2000 Professional.

· DUC 1.2.4 will not be supported with Windows 95, Windows 98, Windows ME, and Windows NT, which are no longer supported by Microsoft.

1.3 Updated Domino Server Support
DUC 1.2.4 will add support for Domino 8.0.1. In other words, Domino 8 requires DUC 1.2.4 and is not supported with DUC 1.2.3. Additionally, the Domino / Notes versions supported by DUC 1.2.4 will be 6.5.4 and greater. Domino / Notes 5 – 6.5.3 are explicitly not supported with DUC 1.2.4.
1.4 New Mail and DWA Templates

One of the big changes with Domino 8 is that there is now a "unified" mail and DWA template. The mail8.ntf has all the stuff in it needed to make DWA work so there is no longer a separate dwa8.ntf template. In earlier versions of Domino, when you registered a user, you would need to select the dwa7.ntf or dwa6.ntf template. 

DUC 1.2.4 contains new mail and dwa (Domino Web Access) templates that will compliment the Lotus Notes 8.0.1 Look and Feel. 
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1.5 Removal of Template Update During csClient Install
In previous versions of DUC, during installation of the csClient component, the user is presented with a dialog asking if the user’s mail file template should be updated as part of the install:
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This panel has been problematic in the past, and the IBM recommendation to customers has always been that during install the checkbox to “Update mail file…..” should not be selected, but instead the mail file design should be updated as a post-install step. To avoid confusion and reduce service calls, this dialog is being removed from the install entirely.
2 Supported Unity Versions  
Domino 8 and DUC 1.2.4 have been qualified for both Cisco Unity 7.0(2) and 5.0(1), but there are two things to note with Unity 5.0(1):

1. As discussed in the About the Anonymous DCOM Issue on the Client section, in order for TRaP to work in the Notes client or Domino Web Access, customers must obtain and install ES48. 

2. The decision was made to not officially support Notes 8 on the Unity server. The reason for this decision is that during Unity Setup, the Service Configuration Wizard (SCW) and the Message Store Configuration Wizard (MSCW) error out when Notes 8 is on the Unity server. These issues are tracked in the following two defects:

· CSCsq33110 — DUC 124: SCW syscheck needs to allow Notes 8 
The fix was just a simple change to SysCheck to allow Notes 8.

· CSCsq33131 — DUC 124: MSCW needs to support Notes 8 on the Unity server 
MSCW needed to be updated to look for the mail8.ntf template when creating the default accounts. It already looks for mail7.ntf and mail6.ntf.

Other than that, having Notes 8 on the Unity server should not be a problem. According to IBM, Notes 8 is API compatible with earlier versions of Notes. 

The Cisco Unity 5.0 System Requirements document does not list Notes 8 as supported on the Cisco Unity 5.0 server. However, 5.0(1) ES49 has the changes to SCW and MSCW that will allow Notes 8 to be installed on the Unity server. If a customer doing a new install of Unity 5.0(1) hits this problem, they’ve got two choices: 

· Uninstall Notes 8 and install Notes 7 (or 6.5.4 or later).
· Obtain ES49 from TAC, with the following instructions:

1. After the Unity Setup part 1 reboot (where the files are copied onto the server), exit out of the Cisco Unity Installation and Preparation Assistant (CUICA).
2. Install ES49 and reboot.

3. Continue to the next step in CUICA, which is launching Service Configuration Wizard. 

3 Supported Version Combinations of Software on Domino and Unity Servers  
The following table shows the supported version combinations of software on Domino and Unity servers. 
	Domino Server Versions
	DUC Version on Domino Server
	Notes Version on Unity Server
	OS on Domino Server 

	8.0.x 
(32-bit version only. The 64-bit version of Domino 8.0 is not supported with DUC.)
	1.2.4
	8.0.x

7.0.x

6.5.4 and later
	IBM AIX 5.3 (64-bit kernel only)

Windows Server 2003 (32-bit version only)

Windows Server 2000

	7.0.x

	1.2.4


	8.0.x (Unity 7.0 only.)

7.0

6.5.4 and later
	· IBM AIX 5.3 (64-bit kernel only)

· Windows Server 2003 (32-bit version only)

· Windows 2000 Server

	7.0.x
	1.2.3
	8.0.x (Unity 7.0 only.)

7.0

6.5.x 
	· IBM AIX 5.3 (64-bit or 32-bit kernel)

· IBM AIX 5.2 (64-bit or 32-bit kernel)

· IBM AIX 5.1 (64-bit or 32-bit kernel)

· Windows Server 2003 (32-bit version only)

· Windows 2000 Server

	6.5.4 and later
	1.2.4 
	8.0.x (Unity 7.0 only.)

7.0

6.5.4 and later
	· IBM AIX 5.3 (64-bit kernel only)

· Windows Server 2003 (32-bit version only)

· Windows 2000 Server

	6.5.x
	1.2.3
	8.0.x (Unity 7.0 only.)

7.0

6.5.x 
	· IBM AIX 5.3 (64-bit or 32-bit kernel)

· IBM AIX 5.2 (64-bit or 32-bit kernel)

· IBM AIX 5.1 (64-bit or 32-bit kernel)

· Windows Server 2003 (32-bit version only)

· Windows 2000 Server


Note the 32-bit and 64-bit stuff in the table. 
Domino 8 comes in 32-bit and 64-bit versions. DUC 1.2.4 works only with the 32-bit version of Domino 8. There are separate install packages for the 32-bit and 64-bit versions of Domino 8. To switch from one to the other involves a total uninstall/reinstall – that’s a big deal. Because of that, we have attempted to be very clear in the Unity System Requirements docs about the need for Domino 8 32-bit.
AIX 5.3 can run either a 32-bit or 64-bit kernel. DUC 1.2.4 requires that AIX be running the 64-bit kernel (sometime called “64-bit mode” but the “64-bit kernel” is more precise). To switch between kernels, you issue a couple of commands and reboot. Not a huge deal, but still we have attempted to make this clear in the Unity System Requirements docs.
Domino 8 also runs on Windows 2003 64-bit; however, DUC 1.2.4 only works with the 32-bit version of Windows. 
4 Supported Version Combinations of Software on Subscriber Workstations
The following table shows the supported version combinations of software on subscriber workstations. Although Domino Web Access (DWA) and iNotes work with many different browsers, only Internet Explorer is supported with DUC.  In other words, only Internet Explorer can be used to listen to or record voice messages in DWA or iNotes; Linux and MAC OS clients are not supported. 

	Operating System on Workstation
	DUC Version on Workstation
	Notes Version on Workstation
	Domino Web Access or iNotes Version and Browser Version

	Windows Vista 

· Enterprise (x86) 

· Business (x86) 

· Business N (x86) 
	· 1.2.4 
	· Notes 8.0.1


	· DWA 8.0.1 

· IE 6.0 SP1, 7



	Windows XP

	· 1.2.4


	· Notes 8.0.1

· Notes 7.0.x
· Notes 6.5.4 and later
	· DWA 8.0.1

· DWA 7.0 and later

· iNotes 6.5.4 and later
· IE 6.0 SP1, 7

	
	· 1.2.3 
· 1.2.2 
	· Notes 7.0 

· 6.5.x 
	· DWA 7.0 

· iNotes 6.5.x 

· IE 6.0 SP1, 7

	Windows 2000 Professional


	1.2.4


	· Notes 8.0.1

· Notes 7.0.x
· Notes 6.5.4 and later
	· DWA 8.0.1

· DWA 7.0 and later

· iNotes 6.5.4 and later
· IE 6.0 SP1, 7

	
	· 1.2.3 
· 1.2.2 
	· Notes 7.0 

· 6.5.x 
	· DWA 7.0 

· iNotes 6.5.x 

· IE 6.0 SP1, 7


5 Documentation Updates

This section describes required and hopeful updates to the customer-facing documentation on cisco.com.

1. Table 1 in the “Compatibility Matrix: Cisco Unity and the Software on Subscriber Workstations” document has been updated as described in the Supported Version Combinations of Software on Subscriber Workstations section.
2. Table 1 in the “System Requirements for Cisco Unity Release 5.0” and “System Requirements for Cisco Unity Release 7.x” documents has been updated as described in the Supported Version Combinations of Software on Domino and Unity Servers section.
Time permitting, we hope to document the following:

1. Update the “Reconfiguration and Upgrade Guide for Cisco Unity Release 5.x (With IBM Lotus Domino)” with procedures that describe various upgrade procedures to DUC 1.2.4 / Domino 8 / Notes 8. 
2. Post the entire contents of the DUC 1.2.4 Help File on cisco.com, or maybe on ciscounitytools.com, TBD. CSCsq35441 has been entered to request this, and IBM has obtained the needed permission from their legal department. There’s a lot of good content in this Help File, but of primary concern is getting word out on the procedure included in the Help File for manually updating the user’s mail file design because of the change described in the Removal of Template Update During csClient Install section.

6 About Updating a User’s Mail File Design

As described in the Removal of Template Update During csClient Install section, after the DUC csClient component is installed on a user’s computer, the user’s mail file design must be manually updated. How to update the mail file design is documented in the Help File that comes with DUC 1.2.4. Because you need either Notes or the Domino Administrator in order to open the DUC Help File, csUCAdminGuide.nsf, the text from the Help File has been copied and pasted in the next section.
6.1 Updating the Mail File Design with the DUC Mail Template File  

After installing IBM(R) Lotus(R) Domino(TM) Unified Communications (DUC) on the client, you must update the design of the active mail file (for example, MAIL8.NSF with that of the DUC mail template installed during DUC client installation (for example, UCMAIL.NTF) before subscribers can use DUC.

· From Domino Designer, copy the design elements from the DUC mail template (for example, ucmail.ntf) to the Notes mail file or mail template (for example, MAIL8.NTF).

OR

· While active in Notes mail, click File - Application - Replace Design, navigate to the installed DUC mail template, for example UCMAIL8.NTF, select it, and respond as prompted.

Note  To replace your mail file design using File - Application - Replace Design, you require at least Manager access to your mail file.

This updates your current mail file with the corresponding Notes mail template, for example MAIL8.NTF elements plus the necessary additional elements in the DUC mail template, for example UCMAIL8.NTF. 

The DUC mail template files are available on your DUC-enabled Domino server. 

The Notes and Domino 8x template is UCMAIL8.NTF (DWA template is included in UCMAIL8.NTF).

The Notes and Domino 7x templates are UCMAIL7.ntf and UCDWA7.NTF.

The Notes and Domino 6.5.x templates are UCMAIL6A.NTF and UCINOTES6BLUE.NTF.
6.2 About Replacing the Design in Notes Mail
To replace a user’s mail file design in Notes mail:
1. Start Notes, and go into mail.

2. Click File > Application > Replace Design.

3. Select the Domino server that the user is homed on, and select the template (for example, UCMAIL8.NTF), and respond as prompted.

If you do not see the menu option File - Application - Replace Design:

From: http://www-1.ibm.com/support/docview.wss?uid=swg21268395
“Several advanced menu choices in Notes 8 are not displayed by default”
Note: The Advanced menus default to ON if all Notes 8 clients are installed: Notes client, Lotus Domino Designer® client, and Domino Administrator client.

If a Notes-Only install is performed, by default the Advanced Menus are not available. However, the following notes.ini parameter can be supplied through a custom desktop policy or via an MST, and this will enable access to Replace and Refresh Design advanced menu actions: "MenusAdvanced=1"

7 Client Troubleshooting
If a customer has encountered a problem with playing or recording voice messages in either Notes or Domino Web Access, the first step in troubleshooting should always be:

· Check the Windows Firewall. If it’s on, either disable it or make an exception for AvTrapConnectionHolderSvr.exe.

· From the Notes client having difficulty, ping the Unity server name and the Domino server name. This should be done using only the local part of the host name, for example: Unityserver as opposed to the FQDN Unityserver.telecom.acme.com. If you can not ping using this short name then playing and recording voice messages in either Notes or Domino Web Access will not work. Either resolve the problem in DNS or add entries to the hosts file on the client computer.
7.1 TRaP Logging

If problems with TRaP are encountered, enable both DUC and AvTrapConnectionHolderSvr logging as follows.
 To Enable AvTrapConnectionHolderSvr Logging
1. Download DebugView for Windows from:
http://technet.microsoft.com/en-us/sysinternals/bb896647.aspx, to the client computer.
2. On the client computer, run regedit.
3. Go to HKEY_CURRENT_USER\Software\Cisco Systems\Cisco Unity\Media Master.
4. Add a DWORD called "Trace" and sets it to 1.
5. Double-click Dbgview.exe. 

6. On the Options menu, make sure Clock Time and Show Milliseconds are checked. 

7. At this point, you have a choice: click File > Log to File, and enter a filename, or when you're done with the test, click File > Save As, and enter a filename. The "Save As" writes to file everything that is on the DebugView display window. To clear that window, click Edit > Clear Display.
Be sure to either delete the Trace registry key or set the Trace registry key to 0 when you are finished.
To Enable DUC Logging
1. Run regedit. 

2. Go to HKEY_CURRENT_USER\Software\Lotus\DUCS. 

3. Create a new DWORD with the name DebugFlags. 

4. Set the value to hex FFF. 

5. This creates a file called LotusUC.csv in the directory where Notes is installed, which by default for Notes 8 is: C:\Program Files\IBM\Lotus\Notes.
This file gets really big quickly. So set DebugFlags back to 0 when you're finished with the test and delete the file.
8 Defects Verified During Testing

The following defects were verified as fixed in Cisco Unity 7.0(2) multi-lingual release during the DUC 1.2.4 and Domino 8 / Notes 8 testing effort:

	
	Defect
	Headline

	1. 
	CSCsl10216
	DUC: :ucprofilecountchange remains on mailbox after unity removal

	2. 
	CSCsk52998
	SCW: failure to configure AvDsDomino during Unity upgrade or new install

	3. 
	CSCsq33131
	DUC 124: MSCW needs to support Notes 8 on the Unity server


9 Defects Found During Testing

The following defects were found during the DUC 1.2.4 test effort, but have not been fixed yet:
	
	Defect
	Headline

	4. 
	CSCsq79007
	DUC124: TRaP fails in Domino PCA and Notes 8 on Vista

	5. 
	CSCsr20998
	DUC124:TRaP in DWA displays 'Object is not connected to server'

	6. 
	CSCsr21280
	DUC124: A second TRaP playback after RNA causes 'Unspecified error'

	7. 
	CSCsr21092
	DUC124: TRaP plays to phone but subsequent attempts show 'Disconnected'

	8. 
	CSCsr21721
	DUC124: Hang up during TRaP in DWA is not detected

	9. 
	CSCsr21712
	Notes - DUC124: ReplyToAll - CC'd usr hears embedded content in msg body

	10. 
	CSCsr23426
	DUC124: TRaP does not always end a Playback session gracefully.

	11. 
	CSCsr26651
	DUC124: Add/Remove Programs does not completely uninstall DUC124 

	12. 
	CSCsr26568
	DUC124: DWA - Playback of embedded text - Email Msg Send/Reply/Fwd

	13. 
	CSCsr26724
	DUC124: Attempting to install DUC before Notes results in bogus error

	14. 
	CSCsr28586
	NUCCTI process keeps running after closing DWA

	15. 
	CSCsr28859
	DUC124:TRaP continues to record after call is ended
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